ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Laurence Mills-Gahl <>
Subject Re: AW: sql task output suppressing a column
Date Thu, 02 Dec 2010 03:49:39 GMT
The problem seems to have been somewhere in the difference between sun
java libraries and gnu. The process worked as expected on Mac OS X but
not on SuSE Linux (until I switched to the Sun JVM and libraries).
I don't know more than that at this point, but the expected behavior is
back. It does seem odd that one column out of three would not display,
but for the moment, I'm going to go with the library mismatch.

On 12/1/10 3:03 PM, Rainer Noack wrote:
> Hmm, sounds like a driver problem (jdbc vs. Native) , not an ant issue.
> -----Urspr√ľngliche Nachricht-----
> Von: Laurence Mills-Gahl [] 
> Gesendet: Mittwoch, 1. Dezember 2010 17:45
> An:
> Betreff: sql task output suppressing a column
> I am having difficulty with the results of a sql task not being the same as
> the results from the sql query in the db environment and I am wondering if
> anybody else has seen this behavior.
> I have a sql task executing the following query:
> c.property_value,
> s.property_value
> FROM center INNER JOIN center_property c ON center.centerKey = c.centerKey
> AND c.property_type = '_CODE'
> LEFT OUTER JOIN center_property s ON center.centerKey = s.centerKey AND
> s.property_type = '_STATUS'
> WHERE center.parentCenterFK = 147
> AND = 1
> The 'center' table is joined to the 'center_property' table twice using the
> property_type _CODE and _STATUS in order to get the values for the _CODE and
> _STATUS. This query gives me the expected results from within the mysql
> commandline tool and gui manager.
> From ant though, I get the code property value and the status property
> value, but the column is always blank.
> I have thought about the column 'name' being a reserved word but quoting the
> column name or making it an alias works with the command line query, but
> gives the same results via ant.
> I have tried moving the sql to an external resource file as well as directly
> in the build file and the output is no different.
> I am stumped as to why the query would work, return the right number of
> rows, but not show any result for the second column. All columns are string
> types. (property_value is VARCHAR(255) and is
> VARCHAR(100))
> Does anybody have any ideas on where to look for the missing names?
> Thank you.
> Larry Mills-Gahl
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: For additional
> commands, e-mail:
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message