ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ramakanth varala <ramakanth.var...@gmail.com>
Subject Re: how to build ant
Date Wed, 17 Nov 2010 17:18:35 GMT
Thanks ,

I have done the same , it's working great.

On Wed, Nov 17, 2010 at 7:32 PM, Antoine Levy-Lambert <antoine@gmx.de> wrote:
> Hello Ramakanth,
>
> you need to download and install somewhere on your hard disk a binary
> version of ant to be able to execute this first step.
>
> Once you have done this, you should do this :
>
> 1 - cd into the directory containing the source version of ant
> 2 - run this command<ant_install_dir>/bin/ant -Ddest=optional -f fetch.xml
>
> on Windows <ant_install_dir>\bin\ant -Ddest=optional -f fetch.xml
>
> what this does is copy the jars which are used by the build process of
> ant into the directory lib/optional.
>
>
>
> Regards,
>
> Antoine
>
> On 11/17/10 12:00 AM, ramakanth varala wrote:
>> Thanks for the reply,
>>
>> in the first step i could not able to build ant , so if i give command
>>
>> ant -Ddest=<ant_home_dir> -f fetch.xml
>>
>> on my console it gives error as
>>
>> ant: command not found
>>
>>
>> so any suggestions where am i going wrong
>>
>>
>> On Wed, Nov 17, 2010 at 2:06 AM, Antoine Levy-Lambert <antoine@gmx.de> wrote:
>>>  On 11/16/2010 9:24 AM, ramakanth varala wrote:
>>>> I downloaded ant-1.8.1 trying to build it in fedora o.s
>>>>
>>>> I have junit*jar in my CLASSPATH.
>>>>
>>>> when i do<ANT_HOME>/ build.sh install-lite gives the following error
>>> Hello Ramakanth,
>>>
>>> You should run this command before building ant :
>>>
>>> ant -Ddest=optional -f fetch.xml
>>>
>>> This command will download the library dependencies of ant and copy them
>>> into the "lib/optional" directory.
>>>
>>> This web page http://ant.apache.org/manual/install.html#buildingant is our
>>> reference concerning building ant.
>>>
>>> It says this "As of version 1.7.0 Ant has a hard dependency on JUnit. The
>>> |fetch.xml| build script will download JUnit automatically, but if you don't
>>> use this you must install it manually into |lib/optional| (download it from
>>> JUnit.org <http://junit.org/>) if you are using a source distribution of
>>> Ant."
>>>
>>>
>>> Regards,
>>>
>>> Antoine
>>>> build:
>>>> Created dir: /home/rvara/Desktop/apache-ant-1.8.1/build/lib
>>>> Compiling 249 source files to
>>>> /home/rvara/Desktop/apache-ant-1.8.1/build/classes
>>>>
>>>> /home/rvara/Desktop/apache-ant-1.8.1/src/main/org/apache/tools/ant/taskdefs/optional/junit/BriefJUnitResultFormatter.java:27:
>>>> package junit.framework does not exist
>>>> import junit.framework.AssertionFailedError;
>>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>> For additional commands, e-mail: user-help@ant.apache.org
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message