ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Ragagnin <>
Subject setting tools.jar without administrative privileges (already searched on google!)
Date Tue, 07 Sep 2010 10:27:03 GMT
when I run ANT i got the error

Unable to locate tools.jar. Expected to find it in
/home/aragag/plar/build.xml:40: Unable to find a javac compiler; is not on the classpath.
Perhaps JAVA_HOME does not point to the JDK.
It is currently set to "/usr/lib/jvm/java-6-openjdk/jre"

here the SCENARIO:
- ANT is right: there is no /usr/lib/jvm/java-6-openjdk/lib/tools.jar file!
- I have found a tools.jar here
/usr/lib/jvm/java-1.5.0-gcj-4.4/lib/tools.jar that could be used(I hope)
- but does NOT EXIST "bin" folder on /usr/lib/jvm/java-1.5.0-gcj-4.4/jre, so
it is a strange java folder
- when I run "update-alternatives --config java" I get this message:
 "There is only one alternative in link group java:
- I'm using Ubuntu 10.04.1 LTS
- I cannot run "su" commands becouse I'm not the administrator (is a computer
of the college)


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message