ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Mackley" <Aaron.Mack...@dtint.com>
Subject silent install directories
Date Wed, 08 Sep 2010 20:59:47 GMT
I am creating a complete install package that installs several other
silent installs. I have all but one working, which causes a unique
problem:

 

One  install seems to require that it be executed from the same
directory as it is run in. Other installers have not required that; I
simply called their application from the correct path , like this:

 

<exec executable="${apps.dir}/SpecificApp/Installer.exe"/>

 

However, a similar call in this application failed (followed by
appropriate arguments) continued to fail:

 

<exec executable="${apps.dir}/SpecificApp2/setup.exe">

 

 

I found that using a batch file resulted in the same failure if I called
the location, but in the batch file, if I did this

 

cd appsdir/SpecificApp2

setup.exe (with appropriate arguments)

 

 (Or if I simply called a separate batch file with that
information-which I don't want to do)

It executed correctly.

 

 

In this case, it seems that this SpecificApp2 requires the command
Prompt to be in the same directory as the executable. This is very
annoying, but I have not found a working solution, other than executing
a simple batch file to change the directory and call the setup.exe.

 

 

Is there a way to do this in ANT without calling a batch file?

 

 

 

Aaron Mackley   |  QA Engineering  |  Digital Technology International
| 801-853-5000  |  aaron.mackley@dtint.com
<mailto:aaron.mackley@dtint.com> 

Transform profitably with our new Targeted Audience Solutions and DTI
Cloud. Get started at www.dtint.com
<file:///C:\Documents%20and%20Settings\amackley\Application%20Data\Micro
soft\Signatures\www.dtint.com> .


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message