ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Laura Dean <lgd...@cyrusinnovation.com>
Subject Re: junit tests running slower in 1.8 than in 1.7
Date Thu, 22 Jul 2010 13:29:03 GMT
On Wed, Jul 21, 2010 at 7:26 PM, Martin Gainty <mgainty@hotmail.com> wrote:
>
> what processor have you implemented in your testbed platform?

On this particular machine, windows reports:
Intel(R) Core(TM) i7 CPU   940 @ 2.93 GHz

> how much ram on your testbed platform?

6 GB

We've seen the same behavior on our less powerful machines, though.


So it looks like, on your machine, taking out fork=yes doesn't result
in any speedup.  Do you also find that switching down to ant 1.7.1
doesn't make a difference?

Merci / vielen Dank,

Laura

>
>
> //With fork:
>
> \ANT\apache-ant-1.8.0\apps\test-project>ant test
> Buildfile: build.xml
>
> test:
>    [junit] Testsuite: SomeJUnitTest
>    [junit] Tests run: 4, Failures: 0, Errors: 0, Time elapsed: 0.203 sec
>    [junit]
>    [junit] Testsuite: SomeOtherJUnitTest
>    [junit] Tests run: 4, Failures: 0, Errors: 0, Time elapsed: 0.157 sec
>    [junit]
>    [junit] Testsuite: YetAnotherJUnitTest
>    [junit] Tests run: 4, Failures: 0, Errors: 0, Time elapsed: 0.157 sec
>    [junit]
>
> ActualTotal=.517s
>
> BUILD SUCCESSFUL
>
> Total time: 2 seconds
>
>
>
> //without fork
> \ANT\apache-ant-1.8.0\apps\test-project>ant test
> Buildfile: build.xml
>
> test:
>    [junit] Testsuite: SomeJUnitTest
>    [junit] Tests run: 4, Failures: 0, Errors: 0, Time elapsed: 0.204 sec
>    [junit]
>    [junit] Testsuite: SomeOtherJUnitTest
>    [junit] Tests run: 4, Failures: 0, Errors: 0, Time elapsed: 0.156 sec
>    [junit]
>    [junit] Testsuite: YetAnotherJUnitTest
>    [junit] Tests run: 4, Failures: 0, Errors: 0, Time elapsed: 0.157 sec
>    [junit]
>
> ActualTotal=.517s
>
> BUILD SUCCESSFUL
> Total time: 1 second
> E:\ANT\apache-ant-1.8.0\apps\test-project>without fork
>
>
> apparently Total time display is inaccurate
>
>
>
> ?
>
> Martin Gainty
> ______________________________________________
> Verzicht und Vertraulichkeitanmerkung/Note de déni et de confidentialité
>

>
>> Date: Wed, 21 Jul 2010 18:33:14 -0400
>> Subject: junit tests running slower in 1.8 than in 1.7
>> From: lgdean@cyrusinnovation.com
>> To: user@ant.apache.org
>>
>> My team has a unit test suite that ran in about a minute and a half
>> with ant 1.6.5 (and 1.7.1), but now takes over 4 minutes with ant
>> 1.8.1 (or 1.8.0).  Has anyone else had this problem?  The closest I've
>> found via google is here, but it doesn't shed much light on the
>> subject:
>>
>> http://netbeans.org/bugzilla/show_bug.cgi?id=182263
>>
>> We're running junit with fork=yes and forkmode=once.  With forking
>> turned off, the tests run much faster, about the same as in 1.7.  (But
>> we want the forking for other reasons.)
>>
>> We're running under Windows, with jdk 1.6 and junit 4.5.
>>
>> Have you seen this problem and worked around it?  Is it a known issue,
>> or a problem with our configuration?
>>
>> For the curious, I've created a simplified project here:
>> http://web.mit.edu/lgdean/Public/test-project.zip .  I've also
>> attached test results below, showing the difference (with much smaller
>> numbers), and a snippet of the build.xml file.  Any advice would be
>> appreciated.
>>
>> Thanks,
>>
>> Laura
>>
>>
>>
>> C:\ant-trouble\my-project>ant -version
>> Apache Ant version 1.7.1 compiled on June 27 2008
>> C:\ant-trouble\my-project>ant test
>>
>> test:
>>     [junit] Testsuite: SomeJUnitTest
>>     [junit] Tests run: 4, Failures: 0, Errors: 0, Time elapsed: 0.042 sec
>>     [junit]
>>     [junit] Testsuite: SomeOtherJUnitTest
>>     [junit] Tests run: 4, Failures: 0, Errors: 0, Time elapsed: 0.032 sec
>>     [junit]
>>     [junit] Testsuite: YetAnotherJUnitTest
>>     [junit] Tests run: 4, Failures: 0, Errors: 0, Time elapsed: 0.034 sec
>>     [junit]
>>
>>
>> C:\ant-trouble\my-project>ant -version
>> Apache Ant version 1.8.1 compiled on April 30 2010
>> C:\ant-trouble\my-project>ant test
>>
>> test:
>>     [junit] Testsuite: SomeJUnitTest
>>     [junit] Tests run: 4, Failures: 0, Errors: 0, Time elapsed: 0.044 sec
>>     [junit]
>>     [junit] Testsuite: SomeOtherJUnitTest
>>     [junit] Tests run: 4, Failures: 0, Errors: 0, Time elapsed: 0.122 sec
>>     [junit]
>>     [junit] Testsuite: YetAnotherJUnitTest
>>     [junit] Tests run: 4, Failures: 0, Errors: 0, Time elapsed: 0.108 sec
>>     [junit]

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message