ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Leif Ershag <l...@ershag.se>
Subject Re: Unsupported class version error
Date Tue, 27 Jul 2010 12:28:27 GMT
What java-version are you running ant with? It looks like the jsch-lib is
compiled with a higher versionnr than you support?

//Leif Ershag

On Tue, Jul 27, 2010 at 1:31 PM, Lis Maria <lismariain@gmail.com> wrote:

> Hi,
>
> I am trying to copy a zip file to a remote machine using the ant scp task.
> The jar file required for this task jsch-0.1.43 is also put inside the ANT
> lib folder. But i get the below exception while this target gets triggered
>
> BUILD FAILED
> java.lang.UnsupportedClassVersionError: Bad version number in .class file
>        at java.lang.ClassLoader.defineClass1(Native Method)
>        at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
>        at
> java.security.SecureClassLoader.defineClass(SecureClassLoader.java:12
> 4)
>        at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
>        at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
>        at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
>        at java.security.AccessController.doPrivileged(Native Method)
>        at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
>        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
>        at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
>        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
>        at java.lang.Class.forName0(Native Method)
>        at java.lang.Class.forName(Class.java:164)
>
>
>
> Can some one help?
>
> Thanks,
> Lis Thomas
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message