ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Hirschhorn <ghirschh...@fetch.com>
Subject RE: Ant 1.7.1, Xalan and Java 1.6.0_17
Date Fri, 07 May 2010 13:45:00 GMT
We don't use the Xalan shipped with Java -- we substitute our preferred version via the java
endorsed directories mechanism.  When Xalan was first included with Java several years ago,
there was a bug in the Xalan version shipped, but fixed in the latest version of Xalan.  So
we started using "-Djava.endorsed.dirs" for all of our Java apps (see http://java.sun.com/javase/6/docs/technotes/guides/standards/)
and we include our preferred version of Xerces and Xalan in this directory.


-----Original Message-----
From: Knuplesch, Juergen [mailto:Juergen.Knuplesch@icongmbh.de] 
Sent: Friday, May 07, 2010 5:48 AM
To: Ant Users List
Subject: Ant 1.7.1, Xalan and Java 1.6.0_17

Hello,

 

I found out that the xalanimpl shipped with Ant1.7.1 is probably
incompatible to Java1.6.0_17, because

 

Java1.6 is shipped with a different xalan version

When I run Ant together with Java 1,6.0_17 I get a certain error

When I remove xalanimpl in the ANT lib dir I don't get this error

When I run this with Java1.5.0_16 I do not get this error

 

So either the shipped xalan is buggy or incompatible or both.

 

Is there already a common solution to solve this issue?

 

I ask because I have a lot of builds. Some use Java 1.5 and some Java
1.6.

 

 

Regards Juergen

 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message