ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Levy-Lambert" <anto...@gmx.de>
Subject Re: RE: Copy task fails on AIX & Suse Linux 9
Date Fri, 28 May 2010 19:52:14 GMT
Hi,

I think that we have started to use NIO in Ant 1.8.x

A bug has been identified recently in this area, and fixed in the sources in subversion.

If this is available to you, could you download the latest sources and build and from source
?

It would be interesting to know if the bug fix that Stefan did recently fixes your issue also.

Regards,

Antoine
-------- Original-Nachricht --------
> Datum: Thu, 27 May 2010 23:34:34 -0400
> Von: "St. Denis, David" <david.stdenis@siemens.com>
> An: "user@ant.apache.org" <user@ant.apache.org>
> Betreff: RE: Copy task fails on AIX & Suse Linux 9

> I found that the Ant 1.8 copy task has problems on SLES9 as well.
> 
> parsing buildfile
> jar:file:/uhome/dsd/bin/neutral/ant-1.8.1/lib/ant.jar!/org/apache/tools/ant/antlib.xml
with URI =
> jar:file:/uhome/dsd/bin/neutral/ant-1.8.1/lib/ant.jar!/org/apache/tools/ant/antlib.xml
from a zip file
>      [copy] Copying 1 file to /plm/svnas/uhome/dsd
>      [copy] Copying /plm/svnas/uhome/dsd/foo to /plm/svnas/uhome/dsd/foo2
> 
> BUILD FAILED
> /plm/svnas/uhome/dsd/copy.xml:3: Failed to copy /plm/svnas/uhome/dsd/foo
> to /plm/svnas/uhome/dsd/foo2 due to Invalid argument
>         at
> org.apache.tools.ant.taskdefs.Copy.doFileOperations(Copy.java:853)
>         at org.apache.tools.ant.taskdefs.Copy.execute(Copy.java:523)
> 
> granularity option on copy had no effect, local disk vs nfs mount had no
> effect. Sles10 works okay though.
> 
> Thanks
> -dave
> 
> From: St. Denis, David
> Sent: Wednesday, May 26, 2010 9:03 AM
> To: 'user@ant.apache.org'
> Subject: Copy task fails on AIX
> 
> 
> <project>
> <echo message="junk" file="foo" />
> <copy verbose="true" file="foo" tofile="foo2" />
> </project>
> 
> Ant copy task fails to copy file properly on AIX with Ant 1.8.0 and 1.8.1.
> The files appear to copy but end up empty.
> Switching between Java 1.5 and 1.6 had no effect when using Ant 1.8 or
> 1.8.1, but switching back to Ant 1.7 the copy task started working again.
> 
> Apache Ant version 1.7.0 compiled on December 13 2006
> Buildfile: copy.xml
> Detected Java version: 1.6 in:
> /plm/svnas/tc_ref/TOOLBOX/aix/JDK/jdk1.6.0_00/jre
> Detected OS: AIX
>      [copy] Copying 1 file to /plm/svnas/uhome/dsd
>      [copy] Copying /plm/svnas/uhome/dsd/foo to /plm/svnas/uhome/dsd/foo2
> 
> svibm006 (~) [27]la foo*
> -rw-r--r--    1 dsd      pdmusr            4 May 26 08:54 foo
> -rw-r--r--    1 dsd      pdmusr            4 May 26 08:54 foo2
> 
> 
> Apache Ant version 1.8.1 compiled on April 30 2010
> Buildfile: /plm/svnas/uhome/dsd/copy.xml
> Detected Java version: 1.6 in:
> /plm/svnas/tc_ref/TOOLBOX/aix/JDK/jdk1.6.0_00/jre
> Detected OS: AIX
>      [copy] Copying 1 file to /plm/svnas/uhome/dsd
>      [copy] Copying /plm/svnas/uhome/dsd/foo to /plm/svnas/uhome/dsd/foo2
> 
> svibm006 (~) [30]la foo*
> -rw-r--r--    1 dsd      pdmusr            4 May 26 08:55 foo
> -rw-r--r--    1 dsd      pdmusr            0 May 26 08:55 foo2
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message