ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shilpa Kulkarni <shilp...@gmail.com>
Subject Need help with jdk1.6.0_11 build
Date Fri, 02 Apr 2010 00:15:02 GMT
Corrected subject for the post below.

On Thu, Apr 1, 2010 at 5:13 PM, Shilpa Kulkarni <shilpayk@gmail.com> wrote:

>
> Hi Everyone,
>
> Just joined the ant mailing list. I am working on getting a build system
> set up. It needs to  produce jdk 1.6.11 binaries. I see following options:
>
> Option 1: Install jdk 1.6.0_11 on the build machine. So ant scripts will
> use it by default. Problem: Not finding this version on web to download.
>
> Option 2: Set build.compiler property to javac1.6. Problem: Here I do not
> have the precision to specify 1.6.0_11. Not sure whether it will really
> matter. Does anyone think it will matter?
>
> Option 3: Do not set build.compiler property. Instead specify target="1.6"
> to javac1.6. Problem: Again I do not have the precision to specify 1.6.0_11.
>
> The build machine is dedicated for one project & will always use same
> compiler version for all its builds. In this case is option 2 better than 3?
>
>
> Is Option1 possible? Can someone help me get this jdk version please?
>
> Shilpa
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message