ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Hirschhorn <ghirschh...@fetch.com>
Subject Ant 1.8 problems with Eclipse
Date Tue, 13 Apr 2010 00:52:25 GMT
I just upgraded from Ant 1.7 to 1.8 and my build files run fine from the command line.  However,
when using Eclipse (3.4.1 - Ganymede), my build files don't run because of this error:

The following error occurred while executing this line: jar:file:/C:/Projects/fetchsoftware/runtime/thirdparty/apache-ant-1.8.0/
 lib/ant.jar!/org/apache/tools/ant/antlib.xml:37: Problem: failed to create task or type componentdef
Cause: The name is
 undefined. Action: Check the spelling. Action: Check that any custom tasks/types have been
declared. Action: Check that any
 &lt;presetdef&gt;/&lt;macrodef&gt; declarations have taken place.

The same build files worked fine when using Ant 1.7.  To get Eclipse to use the Ant version,
I use the "Set Ant Home..."button in Eclipse preferences.

Anyone know what is going on or how to fix it? Ant is clearly finding the 1.8 jar and the
line it complains about is provided by Ant.  Furthermore, the class referred to in the componentdef
("org.apache.tools.ant.taskdefs.condition.And") exists in ant.jar.

Thank you,
Gary

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message