ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pkrish <prasanna.skrish...@gmail.com>
Subject Get bogus error messages using ant verbose, debug modes
Date Sat, 06 Feb 2010 02:12:11 GMT

Hi All,

I am trying to execute a build file in verbose and debug modes. I am getting
messages of the type,

Property "component.key" has not been set

even though in target "private-init" of the build file, I am setting the
value of variable, component.key.

I am attaching my build file
http://old.nabble.com/file/p27476452/test-build.xml test-build.xml 

I am calling the build file from the command line in my local environment as
follows:
The build file uses a .properties file which maps to the properties in the
build file.

ant -v -f ic-build.xml -Dprovisioning.plan=/tmp/ic_latest.properties
-Dplan.override=/tmp/override.properties
-Dframework.lib.dir=$ADE_VIEW_ROOT/faprov/dist/provisioning/framework/lib
-Dconfigframework.lib.dir=$ADE_VIEW_ROOT/faprov/dist/provisioning/configframework/lib
install


My question is that, is this behavior of printing out wrong error messages
expected when you call ant in verbose/debug mode?

Please let me know.

Thanks,
Prasanna

-- 
View this message in context: http://old.nabble.com/Get-bogus-error-messages-using-ant-verbose%2C-debug-modes-tp27476452p27476452.html
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message