ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Connolly <stephen.alan.conno...@gmail.com>
Subject Re: Compile with java 1.5_0.17 run junit tests with 1.6_14
Date Fri, 04 Dec 2009 11:02:45 GMT
yes there is... but I am not an ant expert.

Another technique is to compile with a 1.6 JVM and set target and source to
1.5 and then use animal-sniffer-ant-tasks to verify that your compiled
classes only reference the signatures available in java 1.5.0_17

HTH

-Stephen

2009/12/4 florin.botis <fldrog@yahoo.com>

>
> Hello,
>
>   I have a build.xml file which contains different tasks for compiling and
> running the junit tests. I need to know if there is a way to compile the
> source code with the java 1.5_17 and the run the junit under a 1.6 JVM.
>
> Thanks in advance,
>      Florin
> --
> View this message in context:
> http://old.nabble.com/Compile-with-java-1.5_0.17-run-junit-tests-with-1.6_14-tp26635850p26635850.html
> Sent from the Ant - Users mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message