ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From as rao <asrao.y...@gmail.com>
Subject Re: exec - Cannot run program 'start' CreateProcess error=2
Date Wed, 16 Dec 2009 07:39:54 GMT
Hi

To simplifying the problem statement, when I try to run the default target
in the following build file:

---------------
<project name="test"  basedir="." default="test-target">

<target name="test-target">
        <exec executable="start"
          output="./testproj.log">
      <arg line=" cmd /c notepad"/>
        </exec>
</target>
</project>
---------------

I am getting same error.

cheers
a s


On Wed, Dec 16, 2009 at 11:51 AM, as rao <asrao.yogi@gmail.com> wrote:

> Hi
>
> During starting of app server using ant / build.xml (given by the vendor),
> I faced the following issue:
>
> My env is windows XP, ant 1.7.1
> I am running a build.xml (given by the vendor) to start an app server, from
> DOS prompt. I got the following error:
>
> ---------------------------------------------------------------
> BUILD FAILED
> D:\Installations\11gPS1\build.xml:538: The following error occurred while
> executing this line:
> D:\Installations\11gPS1\build.xml:555: The following error occurred while
> executing this line:
> D:\Installations\11gPS1\build.xml:635: Execute failed: java.io.IOException:
> Cannot run program "start": CreateProcess error=2, The system cannot find the
> file specified
> ---------------------------------------------------------------
>
> when I looked into the build.xml I found that its exec trying to run
> 'start' command using which it intend to run a .cmd file to start the app
> server .
> And interestingly from the same DOS prompt I could run "start" command to
> open a notepad, and so I tend to think that there are no issues with PATH,
> shell, etc.
>
> Any suggestions?
>
>
> cheers
> a s
>



-- 
regards
a s rao

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message