ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From eran123 <e_hau...@hotmail.com>
Subject running shell script on unix
Date Sun, 27 Dec 2009 21:30:48 GMT

Hi,

I hope you can help me figure out what is wrong with my script.
I am trying to run shell script calls stopServer. The ant script is like the
following:

<target name="stop server" depends="" description="stop weblogic server">
		<exec
dir="/clwutabp/clw/aim/clwabp12/J2EEServer/config/ABC-FULL/ABCServer/scripts" 
			vmlauncher="true" executable="/usr/bin/sh"> 
	         	<arg value="-c" />
	         	<arg value="forceShutdownServer"/>
      	</exec>
</target>

However when trying to run the task on Eclipse I receive the following
error:
"The directory you specified does not exist"

The folder exist and also the script. I am trying to run the script via a
diferent user as the owner of the script name forceShutdownServer. I changed
the mod to be 777 for both folder and script but without success to over
come the above error.
Any idea what I am doing wrong?

Please note that I double click on the ant task from remote connection using
NT server. The ant file is located on a unix.

Thanks,
Eran
-- 
View this message in context: http://old.nabble.com/running-shell-script-on-unix-tp26937374p26937374.html
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message