ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Weintraub <qazw...@gmail.com>
Subject Re: Noob question about "delete"
Date Thu, 01 Oct 2009 17:48:29 GMT
Have you looked at: http://ant.apache.org/manual/index.html? That's an on
line manual that describes all the tasks and their parameters. You can also
look at: http://ant.apache.org/manual/CoreTasks/delete.html for the delete
task itself.

There is something called "default excludes" that are not removed when a
delete is done. It could be that there is some file that isn't showing up in
Windows Explorer or the standard "ls" command that this delete command is
not removing. You might want to try setting "defaultexcludes" to "false" in
the Delete task. You can also try the "verbose" flag (to see what it thinks
it is suppose to delete) and the "includeemptydirs" flag too. First try:

<delete verbose="true" dir="${bin.dir}"/>

and see what the output is. Then you can try:

<delete defaultexcludes="true"
    includeemptydirs="true"
    dir="${bin.dir}"/>

and see that you get better results.

2009/10/1 Rodrigo Sebastián Alfonso <rodrigo.s.alfonso@gmail.com>

> Hi guys,
>
> I have a very basic question, i dunno if its my error or just that ANT does
> not allow it, but when I call the delete command, like so:
>
> <delete dir="${bin.dir}" />
>
> All it does is erase the children of ${bin.dir}, but not ${bin.dir} itself,
> I've tested this in windows 7 and ubuntu 9.04 but nothing seems to solve
> it,
>
> Could you give me a hand?? Is there something I can do?
>
> Thanks a lot!!!
>



-- 
David Weintraub
qazwart@gmail.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message