ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From agostonbejo <bejo...@yahoo.com>
Subject <filterchain> messing up accentuated characters
Date Mon, 05 Oct 2009 08:46:21 GMT

Hi!

I've come across this while trying to run some sql insert scripts with ant.
These scripts are first fed to a <filterchain> with a single
<expandproperties/> . The problem is that special characters such as ö, ä,
é, etc. are converted to question marks both in the case of ISO-8859-1 and
UTF-8 files.

I've soon found out that the problem lies in <filterchain> itself! Even if I
run it without any filter readers, it will mess up these characters, i.e.
		<copy todir="${sql.pg.dir}" overwrite="true">
			<fileset dir="${sql.src.dir}">
				<include name="**/*.sql"/>
			</fileset>
			<filterchain>
			</filterchain>
		</copy>
will result in lines where e.g. Coupé becomes Coup? (or Coup??, if the file
was UTF-8.) Running it without the filterchain results in the correct
characters everywhere.

Is there a workaround or a way to fix this?

Thank you,
Agoston
-- 
View this message in context: http://www.nabble.com/%3Cfilterchain%3E-messing-up-accentuated-characters-tp25747126p25747126.html
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message