ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Kimball <m...@cvkimball.com>
Subject RE: Does mail task work on Eclipse on Mac OSX 10.6?
Date Thu, 10 Sep 2009 16:06:24 GMT



When I put either ant-javamail-1.7.0.jar or ant-javamail-1.7.1.jar on my
"Run as" classpath, then the error

java.lang.NoClassDefFoundError: com/sun/mail/util/LineInputStream

reappears.  It's strange that ADDING a jar causes ant to lose
LineInputStream.

I'm guessing that there's an incompatibility among ant 1.7.0 jars and the
activation, mail, and smtp jars.

Does this script run 

<?xml version="1.0"?>
<!--========================================================================-->
<!--========================================================================-->
<!--
             MailTest.xml           
-->
<!--========================================================================-->
<!--========================================================================-->
<project default="main">


<!--========================================================================-->
	<!--
              doit - Do it all         
     -->

<!--========================================================================-->
    <target name="main" > 

	
<echo>---------------------------------------------------------------------------------</echo>
		<echo> </echo>
		<echo>MailTest.xml         ANT_HOME: ${ant.home}</echo>
		<echo> </echo>
	
<echo>---------------------------------------------------------------------------------</echo>
    	
    <mail mailhost="mail.optonline.net" mailport="25" subject="Test">
      <from address="mail@cvkimball.com"/>
      <to address="mail@cvkimball.com"/>
    	<message>Test message.</message>
    </mail>
    	
 		<echo> </echo>
	
<echo>---------------------------------------------------------------------------------</echo>
	</target>
</project>
<!--========================================================================-->
<!--========================================================================-->

on your machine? (At least without the "initialization error".)

Thanks,

Chris




Rebhan, Gilbert wrote:
> 
>  
> 
> -----Original Message-----
> From: Rebhan, Gilbert
> Sent: Thursday, September 10, 2009 5:06 PM
> To: 'Ant Users List'
> Subject: RE: Does mail task work on Eclipse on Mac OSX 10.6?
> 
> /*
> you need mail.jar, activation.jar,smtp.jar and
> ant-javamail.jar but that is already in $ANT_HOME/lib, maybe you need to
> put it on
> the classpath also, if you use "Run As .."
> */
> 
> 
> P.S. :
> activation.jar = JavaBeans Activation Framework , see :
> http://java.sun.com/javase/technologies/desktop/javabeans/jaf/downloads/index.html
> 
> Regards, Gilbert
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Does-mail-task-work-on-Eclipse-on-Mac-OSX-10.6--tp25383764p25385742.html
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message