ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Kimball <m...@cvkimball.com>
Subject Does mail task work on Eclipse on Mac OSX 10.6?
Date Thu, 10 Sep 2009 13:57:36 GMT



With best efforts, can't get the ant 1.7.0 mail task to run under Eclipse on
Mac 10.6. 

  <mail mailhost="mail.optonline.net" mailport="25" subject="Test">
      <from address="mail@xyz.com"/>
      <to address="mail@xyz.com"/>
    	<message>Test message.</message>
  </mail>

produces, in verbose mode,

main:
[antlib:org.apache.tools.ant] Could not load definitions from resource
org/apache/tools/ant/antlib.xml. It could not be found.
        [echo]
---------------------------------------------------------------------------------
        [echo]  
        [echo] MailTest.xml         ANT_HOME: /usr/share/ant
        [echo]  
        [echo]
---------------------------------------------------------------------------------
        [mail] Failed to initialise MIME mail:
org.apache.tools.ant.taskdefs.email.MimeMailer
        [echo]  
        [echo]
---------------------------------------------------------------------------------
BUILD SUCCESSFUL
Total time: 313 milliseconds

What "definitions" is it looking for in resource
org/apache/tools/ant/antlib.xml ?

Thanks,

Chris Kimball
-- 
View this message in context: http://www.nabble.com/Does-mail-task-work-on-Eclipse-on-Mac-OSX-10.6--tp25383764p25383764.html
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message