ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From veena pandit <v.kri...@gmail.com>
Subject Re: Basic question about ant
Date Mon, 31 Aug 2009 13:28:30 GMT
Hi,

I was able to fix the environment variable and run ant from the command
line.  I tried the things you listed below but from eclipse it still gives
me an error saying it does not recognize the program wsgen.

Thanks,

Veena
On Fri, Aug 28, 2009 at 5:12 PM, Gilbert Rebhan <ant@schillbaer.de> wrote:

> veena pandit schrieb:
> > Well,  I wonder why I cant run ant from the command line. Even though the
> > path is set.
> >   Do I have to set classpath as well?
>
> i assume your're on windows ..
>
> ant installation in general =
>
> set ANT_HOME=path/to/root/of/your/antinstalldirectory
> set PATH=%PATH%;%ANT_HOME%/bin
> also take care of addon /extra tasks, see =
> http://marc.info/?l=ant-user&m=124959044401518&w=2
>
> then open up a shell and =
> C:\>ant
> Buildfile: build.xml does not exist!
> Build failed
>
> OK :-)
>
> ant + eclipse =
> to make addon tasks work in eclipse :
> Window | Preferences | Ant | Runtime | Global Entries | Add Jars
>
> you may adjust the environment to your needs via focus on main target in
> outline window, right mouse and choose 3 Ant Build not 2 Ant Build
> Shift+Alt X Q and you'll get a new window where args, classpath,
> environment may be altered
>
> another possibility in your special case, means accessing
> an executable not on path, just use the whole path, means =
>
> project:
>
> <project default="wsgen"
>    <target name = "wsgen">
>    <exec executable="the/whole/path/to/wsgen">
>       <arg line="...
> ...
>
>
>
> Regards, Gilbert
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message