ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Fetzer <elstonk...@yahoo.com>
Subject Re: Calling CYGWIN from Ant in XP
Date Tue, 04 Aug 2009 21:08:06 GMT
Of course I had to fix the file so that it no longer called cygwin.bat since it's in that shell
now (solve the problem of getting to the shell later)...  So running inside the cygwin shell, running:

<exec dir="/cygwin/home/myuser" executable="myShellScript.sh" timeout="1000" outputproperty="returnValue"/>

I get:

BUILD FAILED
c:\cygwin\home\myuser\testCYGWIN.xml:3: Execute failed: java.io.IOException: CreateProcess:
myShellScript.sh error=193

So is there another way to call a unix shell script from windows (locally or on another machine)
and gather the return that works?

Thanks,
Eric


________________________________
From: Eric Fetzer <elstonkers@yahoo.com>
To: Ant Users List <user@ant.apache.org>
Sent: Tuesday, August 4, 2009 2:42:40 PM
Subject: Re: Calling CYGWIN from Ant in XP

Maybe a different issue is under this.  When I run the same build file directly in cygwin,
I get the same error.  From the command line it's fine though.  Does this make more sense?




________________________________
From: Eric Fetzer <elstonkers@yahoo.com>
To: Ant Users <user@ant.apache.org>
Sent: Tuesday, August 4, 2009 1:55:32 PM
Subject: Calling CYGWIN from Ant in XP

I'm trying to call CYGWIN from Ant in XP unsuccessfully.  I need to run a shell script from
winders that returns a value to me.  Tried:

    <exec dir="C:\cygwin" executable="Cygwin.bat" os="Windows XP" timeout="1000" outputproperty="returnValue">
      <arg line="/cygdrive/c/cygwin/home/myuser/myShellScript.sh"/>
    </exec>

I get:

BUILD FAILED
C:\BuildDeployScripts\testCYGWIN.xml:3: Execute failed: java.io.IOException: Crea
teProcess: Cygwin.bat /cygdrive/c/cygwin/home/myuser/myShellScript.sh error=2

Any help?

Thanks,
Eric


      
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message