ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Baranczak <mbaranc...@gmail.com>
Subject javac can't find source files
Date Thu, 13 Aug 2009 16:30:30 GMT
I'm having a very strange problem with Ant on my new computer. It's a
Mac mini-tower with 2 Xeon processors, and I'm dual-booting it with Mac
OS and Ubuntu Linux. I have a secondary hard drive (HFS+) that I use for
sharing data between the two operating systems - this includes all my
software projects. 

When I tried to build one of them under Ubuntu, the build failed. After
some digging around, I realized that javac is not seeing the source
files - when running with -verbose, I see this:

[javac] No sources found.

The weird part is that the exact same projects work on a different
Ubuntu machine, and on Mac OS - but the REALLY WEIRD part is that it
also works when I copy the project from the HFS drive to my Linux home
directory. 

I welcome any suggestions. Also, here's a sample build.xml that I'm
using:

<?xml version="1.0" encoding="UTF-8"?>
<project name="test" default="javac">

    <target name="javac">
        <mkdir dir="classes"/>
        <javac srcdir="src"
               destdir="classes">
        </javac>
    </target>

</project>

-MB




---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message