ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scot P. Floess" <sflo...@nc.rr.com>
Subject Re: annotations are only available if source level is 5.0
Date Wed, 29 Jul 2009 12:29:32 GMT

Interesting...  If you are running 1.6.0_0 - there should be absolutely no 
reason @Override is failing compilation...

That is, unless your <javac> task has a target/source attribute of 1.4 or 
less...

For example:

<javac target="1.4" source="1.4" ...

You will need to search for build.xml or something like it to find the 
<javac> task call...



On Wed, 29 Jul 2009, jann1 wrote:

> Scot P. Floess schrieb:
>> 
>> Which version of Java do you have on your system?  If its stock 1.5+ it 
>> should just work without using the <javac> target attribute...
>
> java version 1.6.0_0
>
>> If all else fails I believe you can just do this:
>> 
>> <javac target="1.5" ...
>
> where to this <javac target="1.5" ... ????
>
> greetings
> Hermann
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>

Scot P. Floess
27 Lake Royale
Louisburg, NC  27549

252-478-8087 (Home)
919-890-8117 (Work)

Chief Architect JPlate   http://sourceforge.net/projects/jplate
Chief Architect JavaPIM  http://sourceforge.net/projects/javapim

Architect Keros          http://sourceforge.net/projects/keros

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message