ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthew Wyatt <matthew.a.wy...@gmail.com>
Subject Problems using tarfileset to set a directory's mode
Date Tue, 21 Jul 2009 00:14:27 GMT
Hi all,
   I'm trying to set a particular directory to mode 777 using tarfileset,
and it's not working. The task looks like:

    <tar destfile="my-tar-file.tar.gz" compression="gzip">
      <tarfileset dir="${tgt.TARGET_DIR}" uid="999" gid="99">
        <exclude name="**/Verify"/> <!-- probably redundant with the
following exclude: -->
        <exclude name="**/Verify/*"/>
      </tarfileset>
      <tarfileset dir="${tgt.TARGET_DIR}" uid="999" gid="99" mode="777">
        <include name="Verify"/>
        <include name="**/Verify/*"/>
      </tarfileset>
    </tar>

I'd like the Verify/ *directory* in the tar file to be set to 777, but it's
always 755.  All the files in the Verify/ directory are set to 777, but not
the directory itself.  I've tried a few different permutations on the
<include>s, but none have worked.  I've tried this on a SunOS box, with Ant
1.7.0, and Windows XP with Ant 1.7.1.
   Either I'm setting the path improperly (entirely possible), or tarfileset
can't set the mode of a directory.  I've looked on the wiki and I've googled
for ideas, to no avail.  Any help is appreciated.
-Matt

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message