ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From starkc <sta...@tessco.com>
Subject ant unable to find build.xml in another directory?
Date Fri, 10 Jul 2009 14:35:28 GMT

As part of compiling my projects in windows, I am required to execute a
second ant task, defined in my build.xml as follows:

<target name="maint">
	<exec failonerror="yes" executable="ant.bat" dir="../maintenance">
  <arg value="ejb"/>
  </exec>
</target>

However, every time I try to run this, I get the following error:

maint:
     [exec] Buildfile: build.xml does not exist!
     [exec] Build failed

However, if I go to that directory and specificially run ant in it, it will
compile correctly.  I have tried running ant with the -verbose and -debug
flags, and there is no extra information given about the situation, and have
tried adding <echo> statements in the build.xml to see what directory ant is
looking for the build.xml, to no avail.  This feels like a path problem of
some kind, but I seem to have everything set up properly...

My environment variables are set as follows:
JAVA_HOME  = C:\jdk1.5.0
ANT_HOME = c:\dev-jboss\ant
PATH = [snip] c:\dev-jboss\ant\bin;

Running Ant version: Apache Ant version 1.5.1 compiled on October 2 2002


Any help would be appreciated.
-- 
View this message in context: http://www.nabble.com/ant-unable-to-find-build.xml-in-another-directory--tp24428338p24428338.html
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message