ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jaybytez <jayby...@gmail.com>
Subject Ant works in Dos Window but not Cygwin Window
Date Tue, 09 Jun 2009 18:00:10 GMT

I just pulled down the latest 1.7.1 to try and resolve an issue I have been
having lately with my Ant instance 1.7.0.

I am not sure if I should really be posting this on Cygwin's forum, but I
can open an instance of DOS prompt and type ant -version and correctly get
the version echoed to the screen.  If I open up a cygwin window and type ant
-version, I get the following error:

$ ant -version
Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/tools/ant/
launch/Launcher
Caused by: java.lang.ClassNotFoundException:
org.apache.tools.ant.launch.Launche
r
        at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:276)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)

My ANT_HOME is set correctly, and I include ANT_HOME/bin in the PATH
environment variable as well.

Is there anything else I should be looking at to resolve this?

Thanks, jay
-- 
View this message in context: http://www.nabble.com/Ant-works-in-Dos-Window-but-not-Cygwin-Window-tp23948225p23948225.html
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message