ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ashley Williams <ashpub...@mac.com>
Subject Re: Java in JDK but ANT can't find it!
Date Thu, 14 May 2009 15:36:08 GMT
I did a lot of copying and pasting from this website to get my own  
code up and running:

http://www.ibm.com/developerworks/websphere/library/techarticles/0502_gawor/0502_gawor.html

However I still believe the problem is with your environment rather  
than your code.
Try editing the ant batch file or shell script in order to print out  
JAVA_HOME and PATH and
just at the point where it runs org.apache.tools.ant.launch.Launcher.

Then print out all environment variables at the top of your build.xml  
file. And print out
java.home at the start of your java application.

If you are forking the compiler, could it not be inheriting the  
environment correctly?

On 14 May 2009, at 16:22, Cole, Derek E wrote:

> Ashley,  can you post a snippet of how you set up the project you  
> launch
> programmatically from java?
>
> What does your build file that you are running from java contain in  
> it?
>
> -----Original Message-----
> From: Ashley Williams [mailto:ashpublic@mac.com]
> Sent: Thursday, May 14, 2009 10:54 AM
> To: Ant Users List
> Subject: Re: Java in JDK but ANT can't find it!
>
> Check your PATH to make sure you are launching your application from
> the jdk and not the jre.
>
> I launch programatically and I don't get these errors with the same
> version of ant so it does
> sound as if the problem lies outside of ant.
>
> On 14 May 2009, at 15:46, David Nemer wrote:
>
>> This is what I'm trying to tell you! My JAVA_HOME it is set as
>> /opt/jdk1.6.0_06 I've triple checked it on my bash file! I also
>> check with
>> echo $JAVA_HOME and which java, they all tell the right path, but
>> not ANT!
>> This is why I don't understand where does ant get this /jre !!
>> --
>> David Nemer
>> Sent from Kaiserslautern, RP, Germany
>>
>> On Thu, May 14, 2009 at 4:42 PM, Ashley Williams <ashpublic@mac.com>
>> wrote:
>>
>>> In your description you say that  JAVA_HOME=/opt/jdk1.6.0_06/jre
>>>
>>> Seriously, try JAVA_HOME= /opt/jdk1.6.0_06 instead
>>>
>>>
>>>
>>>
>>> On 14 May 2009, at 15:28, Cole, Derek E wrote:
>>>
>>> When I had this problem, I KNOW that JAVA_HOME was set correctly. I
>>>> still ran into the problem. The OP here also said JAVA_HOME was set
>>>> correctly. There is some missing step here that prevents the ant
>>>> Project
>>>> instance from knowing which Java to use.
>>>>
>>>> -----Original Message-----
>>>> From: Ashley Williams [mailto:ashpublic@mac.com]
>>>> Sent: Thursday, May 14, 2009 9:56 AM
>>>> To: Ant Users List
>>>> Subject: Re: Java in JDK but ANT can't find it!
>>>>
>>>> It looks like you are pointing to the jre not the jdk.
>>>> Try repointing the JAVA_HOME environment variable to the jdk
>>>> directory
>>>> instead,
>>>>
>>>>
>>>> On 14 May 2009, at 13:15, David Nemer wrote:
>>>>
>>>> Hello Everyone,
>>>>>
>>>>> I am running ANT programmatically in JAVA. So, my task is to
>>>>> build the
>>>>> BUILD.XML.
>>>>> I'm able to do so, but it throws an exception saying:
>>>>>
>>>>> /scratch2/nemer/test/xfire/build.xml:5: The following error
>>>>> occurred
>>>>> while
>>>>> executing this line:
>>>>> /scratch2/nemer/test/xfire/build-common.xml:81: Unable to find a
>>>>> javac
>>>>> compiler;
>>>>> com.sun.tools.javac.Main is not on the classpath.
>>>>> Perhaps JAVA_HOME does not point to the JDK.
>>>>> It is currently set to "/opt/jdk1.6.0_06/jre"
>>>>>
>>>>> But in the end it says: BUILD SUCCESSFUL (but it still throws that
>>>>> exception).
>>>>>
>>>>> I already set all of my environment variables to  /opt/ 
>>>>> jdk1.6.0_06/
>>>>> (JAVA_HOME and also in PATH), which is a JDK! And even on the  
>>>>> error
>>>>> message
>>>>> it says that the java is set to /opt/jdk1.6.0_06/jre (which is a
>>>>> JDK, I
>>>>> don't know where it gets the jre from).
>>>>>
>>>>> So, does any one know how can I solve this problem? Is there a
>>>>> configuration
>>>>> file in ANT that we need to set up! I'm stuck there!!
>>>>>
>>>>> I'm running the ant 1.7.1.
>>>>>
>>>>> Cheers,
>>>>> --
>>>>> David Nemer
>>>>> Sent from Saarbrucken, SL, Germany
>>>>>
>>>>
>>>>
>>>>
> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>>>> For additional commands, e-mail: user-help@ant.apache.org
>>>>
>>>>
>>>>
> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>>>> For additional commands, e-mail: user-help@ant.apache.org
>>>>
>>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>>> For additional commands, e-mail: user-help@ant.apache.org
>>>
>>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message