ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rebhan, Gilbert" <Gilbert.Reb...@huk-coburg.de>
Subject Probs with UNC when starting ant171 from batch
Date Tue, 19 May 2009 11:47:33 GMT

Hi,

finally switching from Ant165 to Ant171 ..
When writing ant scripts on windows, we start the scripts
out of the editor (PSPad, UltraEdit ..) via batchfile.
One of my teammates uses UNC (jdk5, Windows 2000)

The batchfile looks like that =

@ echo off

set ANT_HOME=\\machine\c$\ant
set ANT_ARGS= ...
set JAVA_HOME= ...
set ANT_OPTS= ...
set PATH=%JAVA_HOME%\bin;%ANT_HOME%\bin;%PATH%

: DEBUG
:call ant -debug -f  %1

: DEFAULT
call ant -f  %1

...


The use of UNC worked with ant 1.6.5 whereas with ant 1.7.1 he get's =
java.lang.ClassNotFoundException: org.apache.tools.ant.Main
        at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:255)
        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)


Any ideas or workarounds ?


Regards, Gillbert

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message