ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Nemer <davidne...@gmail.com>
Subject Re: Java in JDK but ANT can't find it!
Date Sat, 16 May 2009 19:25:57 GMT
Just a remark, when I run the application and /opt/jdk1.6.0_06/lib/tools.jar
to the classpath. It gives me a different error message:  "Compile failed;
see the compiler error output for details." there is no error msg and it
still says BUILD SUCCESSFUL


--
David Nemer
Sent from Kaiserslautern, RP, Germany

On Sat, May 16, 2009 at 9:11 PM, David Nemer <davidnemer@gmail.com> wrote:

> Hello Michael,
>
> here is my code on how I'm invoking Ant:
>
>             Project p = new Project();
>             p.setUserProperty("ant.file", buildFile.getAbsolutePath());
>             DefaultLogger consoleLogger = new DefaultLogger();
>             consoleLogger.setErrorPrintStream(System.err);
>             consoleLogger.setOutputPrintStream(System.out);
>             consoleLogger.setMessageOutputLevel(Project.MSG_INFO);
>             p.addBuildListener(consoleLogger);
>             p.fireBuildStarted();
>             p.init();
>             ProjectHelper helper = ProjectHelper.getProjectHelper();
>             p.addReference("ant.projectHelper", helper);
>             helper.parse(p, buildFile);
>             p.executeTarget(p.getDefaultTarget());
>
> Michael, I read somewhere that when you invoke ANT in java, it runs in the
> same JVM, and forking the ANT process might solve it. Do you have any idea
> how would I code this?? Make Ant ran in another JVM?
>
>
> --
> David Nemer
> Sent from Kaiserslautern, RP, Germany
>
> On Sat, May 16, 2009 at 9:03 PM, Michael Ludwig <milu71@gmx.de> wrote:
>
>> David Nemer schrieb am 16.05.2009 um 20:51:31 (+0200):
>>
>> > nemer@kubrick:~$ java -jar
>> /home/nemer/apache-ant-1.7.1/lib/ant-launcher.jar
>> > -version
>> > Apache Ant version 1.7.1 compiled on June 27 2008
>> >
>> > nemer@kubrick:~$ /opt/jdk1.6.0_06/bin/java -jar
>> > /home/nemer/apache-ant-1.7.1/lib/ant-launcher.jar -version
>> > Apache Ant version 1.7.1 compiled on June 27 2008
>> >
>> > so just running JAVA worked as well as running /opt/jdk1.6.0_06/bin/java
>>
>> So tools.jar is found alright. It's an environmental problem, either in
>> the ant shell script (has that been tampered with?) or, more likely, the
>> shell script you're using to launch it.
>>
>> Michael Ludwig
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>> For additional commands, e-mail: user-help@ant.apache.org
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message