ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Iwud H8u <iwud...@hotmail.com>
Subject ANT does not create index.html when using javadoc task
Date Wed, 13 May 2009 16:40:47 GMT

Hi,

I am having trouble exporting javadocs using an Ant task. Ant seems to
generate the javadocs alright but it does not create the index.html file for
the java docs. In fact, the only files in the output directory are :

constant-values.html
overview-frame.html
package-list
resources
serialized-form.html
com <-- directory corresponding to root of package structure

When I run javadocs from Eclipse on the same source, I get the following
directory structure in the output directory:

allclasses-frame.html
allclasses-noframe.html
constant-values.html
deprecated-list.html
help-doc.html
index-files
index.html
overview-frame.html
overview-summary.html
overview-tree.html
package-list
resources
serialized-form.html
stylesheet.css
com <-- directory corresponding to root of package structure

My ant task looks like :
    <target name="generate_documentation" depends="compile"
description="Generates java doc">
        <javadoc
            destdir="${app.dir}/docs/javadocs"
            author="true"
            version="true"
            use="true"
            windowtitle="Test API" 
            >
            
            <packageset dir="${src.dir}" defaultexcludes="yes">
                <include name="com/foo/app/**"/>
                <exclude name="**/test/**"/>
                <exclude name="**/xxx/**"/>
            </packageset>
            
            <doctitle><![CDATA[<h1>Test</h1>]]></doctitle>
            <bottom><![CDATA[Copyright &#169; Company. All Rights
Reserved.]]></bottom>
            <tag name="todo" scope="all" description="To do:"/>
            <link offline="true"
href="http://java.sun.com/j2se/1.5.0/docs/api/" packagelistLoc="C:\tmp"/>
            <link
href="http://developer.java.sun.com/developer/products/xml/docs/api/"/>
        </javadoc>
    </target>

I have also tried setting the values of 'noindex' to false but it does not
seem to help. Can anyone tell me if I am doing something wrong here?

Thanks so much
-- 
View this message in context: http://www.nabble.com/ANT-does-not-create-index.html-when-using-javadoc-task-tp23525564p23525564.html
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message