ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From matthew sporleder <msporle...@gmail.com>
Subject Invalid implementation version between Ant core and Ant optional tasks.
Date Thu, 09 Apr 2009 17:21:35 GMT
I know the following problem is pretty common:
Invalid implementation version between Ant core and Ant optional tasks.
 core    : 1.6.5
 optional: null

But the 'optional: null' seems a little rare.  This is especially
strange because this ant is working on another box configured in
(supposedly) exactly the same way.

ant -diagnostics won't work unless I export
CLASSPATH=$ANT_HOME/lib/ant-nodeps.jar, which is strongly discouraged
in the ant documentation.  Spending some time with strace shows this
failure happening immediate after opening
jakarta-ant-1.4.1-optional.jar.

Comparing to the other, working, box mostly shows a lot less opening
of things like ant-vaj.jar and differences in "Tasks availability"
from ant -diagnostics.

How does ant decide which jar's to open?

Working:
-------------------------------------------
 Tasks availability
-------------------------------------------
image : Missing dependency com.sun.media.jai.codec.FileSeekableStream
jdepend : Missing dependency jdepend.xmlui.JDepend

Invalid optional/core (CLASSPATH set as above):
-------------------------------------------
 Tasks availability
-------------------------------------------
image : Missing dependency com.sun.media.jai.codec.FileSeekableStream
telnet : Missing dependency com.oroinc.net.SocketClient
ftp : Missing dependency com.oroinc.net.SocketClient
script : Missing dependency com.ibm.bsf.BSFException

Thanks,
Matt

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message