ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Gainty <mgai...@hotmail.com>
Subject RE: exec on devenv.exe does not output anything
Date Fri, 27 Mar 2009 13:54:07 GMT

Benjamin

2 options
1)
Running as an Administrative User
				
If you wish to run as an administrative user, you must make the following changes to the configuration:Create
an experimental hive by running the following vsregex command:
vsregex getorig 9.0 exp
Remove the /ranu switch from the command line for all configurations.(look at menu option
you will see devenv.exe /RANU option)

In
the project file, 
-change the property RegisterWithCodebase to false,

-the property GacTargetOutput to true, 
-and the property RegisterWithRANU
to false. 

			2)
implement /RANU option that Microsoft prescribes for starting devenv.exe
http://msdn.microsoft.com/de-de/library/bb932482.aspx

Viel Gluck,
Martin 
______________________________________________ 
Verzicht und Vertraulichkeitanmerkung / Disclaimer and confidentiality note 
Diese Nachricht ist vertraulich. Sollten Sie nicht der vorgesehene Empfaenger sein, so bitten
wir hoeflich um eine Mitteilung. Jede unbefugte Weiterleitung oder Fertigung einer Kopie ist
unzulaessig. Diese Nachricht dient lediglich dem Austausch von Informationen und entfaltet
keine rechtliche Bindungswirkung. Aufgrund der leichten Manipulierbarkeit von E-Mails koennen
wir keine Haftung fuer den Inhalt uebernehmen.
This message is confidential and may be privileged. If you are not the intended recipient,
we kindly ask you to  please inform the sender. Any unauthorised dissemination or copying
hereof is prohibited. This message serves for information purposes only and shall not have
any legally binding effect. Given that e-mails can easily be subject to manipulation, we can
not accept any liability for the content provided.






> From: benjamin.calvot@cr2.com
> To: user@ant.apache.org
> Date: Fri, 27 Mar 2009 11:38:32 +0000
> Subject: exec on devenv.exe does not output anything
> 
> 
> Hi everyone,
> 
> I am running an Ant script from Luntbuild in order to build an Visual Studio 8 solution
(set of projects).
> When I run "devenv.exe Complete.sln /build Release" from a command line I get the output
of the build in the DOS box, but when I run the same command with an <exec> task it
does not output any single line:
> 
> 	<exec dir="${basedir}\Complete" executable="devenv.exe" failonerror="true">
> 		<arg line="Complete.sln /build Release"/>
> 	</exec>
> 
> I also tried to run a "cmd.exe /C devenv.exe Complete.sln /build Release" with <exec>
but the result is the same. Do you have an idea why <exec>, in this particular situation,
does not grab any output from the command? I have other <exec> in my build script (mkisofs,
cmd, cvs tag) and they all work fine regarding the output...
> 
> Cheers,
> Benjamin
> 
> CR2
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 

_________________________________________________________________
Express your personality in color! Preview and select themes for HotmailĀ®.
http://www.windowslive-hotmail.com/LearnMore/personalize.aspx?ocid=TXT_MSGTX_WL_HM_express_032009#colortheme
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message