ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dylan Farre <dylan.fa...@gmail.com>
Subject Oracle on Unix help
Date Tue, 03 Mar 2009 18:56:30 GMT
Hi, any help will me much appreciated.
I have been using Incanto for Oracle on Windows, but now I am having some
issues using it on Unix, it sort of works, but gives errors. Also looking at
the website, there is no mention of Unix. I assumed that it would support
it, since that is the Ant philosophy.

A)
If I enter the incorrect database name, I get this error:
ORA-12154: TNS:could not resolve the connect identifier specified
This seems to indicate that it is working. However, the resultproperty gets
set to 122.

B)
If I enter the incorrect user name, I get this error:
ORA-01017: invalid username/password; logon denied
This also seems to indicate that it is working. However, the resultproperty
gets set to 1.

C)
If I enter the correct database connection details, I get this error:
Executing 'sqlplus' with arguments:
'-S'
'/nolog'

The ' characters around the executable and arguments are
not part of the command.
O/S Message: No such file or directory
The resultproperty gets set to 1.

This is when I had my scripts: like this

---------------- exec_AS.sql ----------------------
set pages 21 lines 80 term on echo off verify off feedb on
whenever oserror exit failure
whenever sqlerror exit sql.sqlcode
spool &2 append
connect &&db_user/&&db_pass@&&db_db
start &1

Which called a script that looks like this:

select * from all_users where username = upper('&db_user');

I now changed my script to be like this:
---------------- exec_AS.sql ----------------------
set pages 21 lines 80 term on echo on verify on feedb on
whenever sqlerror exit sql_sqlcode
connect &&db_user/&&db_pass@&&db_db

And not calling the second script. At this stage, I am just verifying
connections. I also removed the <![CDATA[    WHENEVER SQLERROR EXIT
SQL.SQLCODE    ]]> from the SQL task.

C) Now does not return an error when enter the correct connection details.

The results for B is the same. Did not check A yet.

I seem to be making some progress, but I would still appreciate some help or
advice. It seems Incanto is ok, I just don't have much experience with
sqlplus on UNIX.

I guess that I could just use the exec task with some shell scripts, but it
does mean some extra work.

Thanks, its late here, my brain is numb, bedtime.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message