ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henning Lötsch <henning.loet...@vodafone.de>
Subject Re: Problem with using the property task
Date Fri, 13 Mar 2009 15:58:52 GMT
Hello Scott,

look at:
http://ant.apache.org/manual/CoreTasks/property.html
Section "Property Files".

your property file syntax is wrong.

in your case the file vti-new.properties must look like this:
component=vti


Scott Stark schrieb:
> I'm trying to import a set of properties from a property file into my build
> when using the <ant> call. My property file looks something like this:
> 
> <project name="scenario_properties" basedir=".">
>         <property name="component" value="vti"/>
> </project>
> 
> My build file contains this target:
> 
>  <target name="all">
>  <ant antfile="buildfile.xml" target="build-all-test" output="vti-all.log">
>   <property resource="properties_files\vti-new.properties"/>
>  </ant>
>  </target>
> 
> The <antfile> that it's calling (buildfile.xml) contains this target:.
> 
>  <target name="build-all-test">
>   <echo>component name is ${component}</echo>
>  </target>
> 
> But the output of the above target build is simply:
> 
> build-all-test:
>      [echo] component name is ${component}
> 
> Why is the component property not getting passed to my antfile? I've also
> tried a properties file with the "component=vti" syntax and get the same
> result.
> 
> Thank you,
> Scott


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message