ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rinehart, Raleigh" <raleigh.rineh...@ti.com>
Subject RE: rexec task failed with error "can't connect to..."
Date Wed, 18 Feb 2009 18:43:24 GMT


> -----Original Message-----
> From: Anat [mailto:anat.batat@gmail.com]
> Sent: Wednesday, February 18, 2009 3:13 AM
> To: user@ant.apache.org
> Subject: rexec task failed with error "can't connect to..."
> 
> 
> Hi,
> When I run rexec task it fails with the error "can't connect to <Server
> field value>".
> I run it in the following way:
> 
> <rexec userid="<myUser>" password="<myPassword>" server="<my local
machine
> ip>" command="cmd"/>
> 
> I also tried to run the task on other machines but it failed with the same
> error.
> My machine is windows 2008. The final goal is to run the task from linux
> machine on a windows machine.
> Any idea why it fails?
> Is there another command I can use instead?
> 
> thanks,
> Anat

You need to have and rexec service installed on your windows machine in order for this to
work.

There are a few available for windows, cygwin has one, and there is one here (untested by
me) http://sourceforge.net/projects/rshd/

An alternative is to use sshexec, this are requires a ssh service (daemon) on windows, however
there a plenty to choose from.

On a side note, rexec is very insecure, all the cmd info is sent in plain text, including
user name and password.

Hope this helps,
-raleigh
 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message