ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 3akycka <patma...@yahoo.fr>
Subject RE: AW: AW: AW: scite as3 + ant + flex sdk
Date Sat, 28 Feb 2009 18:36:45 GMT

:jumping:

Hello,

I don't know exactly all what I did to do it %-| but I finaly arived to make
it working.

I tried to execute directly mxmlc in the terminal, to verify if it was
running standalone, and he wasn't :
./mxmlc path/Sample.as -o path/Sample.swf

... just nothing append exactly like when I did from scite+ant.

after that I tried to remove and install again java jdk... nothing more

upgrade Ubuntu to 8.10 (independently of my problem with flex), and after
the upgrade, I don't know why when I tryed again to compile I got this error
message (may my problem was this and just did not had a message before ?) :
>/usr/share/ant/bin/ant test
Unable to locate tools.jar. Expected to find it in
/usr/lib/jvm/java-1.5.0-gcj-4.3-1.5.0.0/lib/tools.jar
Buildfile: build.xml

So, I finally fond that It was not the good version of java used on my
computer, and I did that to choose it :
sudo update-alternatives --config java

And again a new bug, the error message was very big and start like that :
[mxmlc] Loading configuration file
/home/aliya/Bureau/Telechargements/flex_sdk_3.2.0.3794/frameworks/flex-config.xml
    [mxmlc] Error: class
org.apache.xerces.util.XMLAttributesMMImpl$AttributeMMImpl cannot access its
superclass org.apache.xerces.util.XMLAttributesImpl$Attribute
..etc

And I finally find how to correct it : 
http://bauhouse.wordpress.com/2008/07/16/actionscript-compiler-error-flex-ant-tasks-bug/
ActionScript Compiler Error - Flex Ant Tasks Bug 

Thank you very much Jan and Martin for your precious help ! :handshake:
-- 
View this message in context: http://www.nabble.com/scite-as3-%2B-ant-%2B-flex-sdk-tp21921594p22264216.html
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message