ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 3akycka <patma...@yahoo.fr>
Subject Re: AW: scite as3 + ant + flex sdk
Date Tue, 10 Feb 2009 20:15:07 GMT


Jan.Materne wrote:
> 
> Maybe we should print another "action":
>   Action: Check that the Jar containing the task is available.
> 

Thank you for your answer !
I did look at your links but didn't find how to repair my problem.

Here what I did :

In the flex sdk folder, there is a "Ant" folder, on this folder there is :
Lib/flexTasks.jar, I copied this file into : /usr/share/ant/lib

In  the flex sdk folder, there is also the file : flexTasks.tasks, I stay it
here, don't know if it need to be move ?
It contains :
mxmlc=flex.ant.MxmlcTask
compc=flex.ant.CompcTask
html-wrapper=flex.ant.HtmlWrapperTask

With scite as3 there is a folder with an example, it contains an
actionscript main class file and a build.xml file,
I copy the the original file but I did changed it a bit to point to the
right folder of the different applications :

<?xml version="1.0" encoding="utf-8"?>
<project name="Sample" basedir=".">
	<taskdef resource="flexTasks.tasks"
classpath="${basedir}/flexTasks/lib/flexTasks.jar" />   (Here  I don't know
if it have to stay, if I did put the flexTasks.jar file into the Ant folder
?)
	<property name="FLEX_HOME" value="/usr/share/flex_sdk_3.0.0.477"/> (Here I
did put the well path to the flex sdk folder on my computer)
	<property name="APP_ROOT" value="."/>
	
	<target name="swf">
		<mxmlc file="${APP_ROOT}/Sample.as" compiler.optimize="true"
output="${APP_ROOT}/sample.swf"> 
			<load-config filename="${FLEX_HOME}/frameworks/flex-config.xml"/>
		</mxmlc>
	</target>
	
	<target name="test">
		<antcall target="swf"/>
		
		<exec
executable="/usr/share/flash_player_9_linux_dev/standalone/release/flashplayer">
(and here again)
			<arg value="${APP_ROOT}/sample.swf"/>
		</exec>
	</target>
	
	<target name="debug">
		<mxmlc file="${APP_ROOT}/Sample.as" compiler.optimize="true" debug="true"
output="${APP_ROOT}/sample-debug.swf">
			<load-config filename="${FLEX_HOME}/frameworks/flex-config.xml"/>
		</mxmlc>
		
		<exec executable="/bin/sh">
			<arg line='-c "x-terminal-emulator -e ${FLEX_HOME}/bin/fdb
${APP_ROOT}/sample-debug.swf"'/>
		</exec>
	</target>
</project>

May be I'm not doing something well in that file ?

If there is some thing more to install for Ant to work, I can't find what it
is ?

:-)







-- 
View this message in context: http://www.nabble.com/scite-as3-%2B-ant-%2B-flex-sdk-tp21921594p21939704.html
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message