ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Reilly" <peter.kitt.rei...@gmail.com>
Subject Re: ANT javac tager option issue
Date Sat, 20 Dec 2008 10:43:57 GMT
What you are getting is a warning and not an error.
The javac compiler is telling you that the code will be illegal in
java 1.5 and higher.

Try the command line version of javac on a test file and see if there is any
command line args that allow the warning to be suppressed. This can
then be used in the <javac> task.

Peter

On Fri, Dec 19, 2008 at 5:11 PM, Eric Wood <EWood@llbean.com> wrote:
> Yes. I figured that out and have that but I still get the same issue.
> Strange.  Here is my task:
>
>
>      <javac srcdir="${dir.java.src}"
>             deprecation="off"
>             debug="${compile.debug}"
>             destdir="${dir.java.bin}"
>             optimize="on"
>             target="1.4"
>             source="1.4"
>             fork="true"
>             nowarn="${compile.nowarn}"
>             memoryMaximumSize="${compile.memory.max}">
>               <patternset refid="compile.patternset" />
>               <classpath refid="classpath.build" />
>      </javac>
>
> I'm curious if it has something to do with the fork.  Curious if it is
> truncating the values somehow on the passed command line. Trying that
> now.
>
> E
>
> -----Original Message-----
> From: Peter Reilly [mailto:peter.kitt.reilly@gmail.com]
> Sent: Friday, December 19, 2008 12:08 PM
> To: Ant Users List
> Subject: Re: ANT javac tager option issue
>
> You need source="1.4" as well.
>
> Peter
>
> On Fri, Dec 19, 2008 at 4:18 PM, Eric Wood <EWood@llbean.com> wrote:
>> My java is a 1.5 compiler, but I running the javac using a target="1.4
>
>> and the output keeps giving me JAVA 1.5 compiler errors:
>>
>>
>>
>>    [javac]
>> /ClearCase_Storage/viewroot/Ecommerce/ecomm_commerce_suite/build_ECOMM
>> _1
>> 5.0_Integration/vob/ecomm_commerce_suite/AppServer/WebSphereCommerceSe
>> rv
>> erExtensionsLogic/src/com/ibm/wcsx/llbean/common/utilities/FieldErrorD
>> at
>> aBean.java:87: warning: as of release 1.5, 'enum' is a keyword, and
>> may not be used as an identifier
>>    [javac] (try -source 1.5 to use 'enum' as a keyword)
>>    [javac]     Enumeration enum = getExceptionData().keys();
>>    [javac]                     ^
>>    [javac]
>> /ClearCase_Storage/viewroot/Ecommerce/ecomm_commerce_suite/build_ECOMM
>> _1
>> 5.0_Integration/vob/ecomm_commerce_suite/AppServer/WebSphereCommerceSe
>> rv
>> erExtensionsLogic/src/com/ibm/wcsx/llbean/common/utilities/FieldErrorD
>> at
>> aBean.java:88: warning: as of release 1.5, 'enum' is a keyword, and
>> may not be used as an identifier
>>    [javac] (try -source 1.5 to use 'enum' as a keyword)
>>    [javac]     while (enum.hasMoreElements()) {
>>
>>
>> Here is my javac task:
>>      <javac srcdir="${dir.java.src}"
>>             deprecation="off"
>>             debug="on"
>>             destdir="${dir.java.bin}"
>>             optimize="on"
>>             target="1.4"
>>             fork="true"
>>             nowarn="on"
>>             memoryMaximumSize="724M">
>>               <patternset refid="compile.patternset" />
>>               <classpath refid="classpath.build" />
>>      </javac>
>>
>> Am I not using this perpoerly. Nay help would be greatly appreciated.
>>
>> Eric
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org For additional
> commands, e-mail: user-help@ant.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message