ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Cambray (BlueXML)" ...@bluexml.com>
Subject Re: Ant : Very slow on Vista
Date Tue, 09 Dec 2008 09:22:52 GMT
Hello,
thanks for your answers.

I run Vista on Safe Mode and re-reun my ant task. I have a time of 2 m 
51s, much better than my 7 minutes but far from the 1 minute on Mac OS 
or Linux (I just run a test on a Mac OS, 4Go RAM, dual core and I have a 
1:26 minute).

For Mark > I don't have network task.
But on my test, and based on what I see there is no specific task that 
take long time just a "cyclic" run / stop. My task do javac, copy files, 
zip and unzip (many times for each) nothing really special..

I can't run new test on the mono core computer  but on a quad core 
machine, on vista, I have a time of 3 to 4 minutes.
And I'm running a 1.7.0 version and both computer.

Thanks.
(and sorry for my english!)



Martin Gainty a écrit :
> Eric-
>
> Sounds as if you have alot of background processes eating up resources (specifically
memory)
> what happens if you start vista with F5 and rerun the ant task?
>
> Martin 
> ______________________________________________ 
> Disclaimer and confidentiality note 
> Everything in this e-mail and any attachments relates to the official business of Sender.
This transmission is of a confidential nature and Sender does not endorse distribution to
any party other than intended recipient. Sender does not necessarily endorse content contained
within this transmission. 
>
>
>
>
>   
>> Date: Mon, 8 Dec 2008 17:21:25 +0100
>> From: ec@bluexml.com
>> To: user@ant.apache.org
>> Subject: Ant : Very slow on Vista
>>
>> Hello,
>> I searched and web and don't find a lot of thing for my problem so I 
>> come to you to know more about this.
>>
>> I word on a project with different people having different kind of 
>> installation (Linux, Mac Os, Xp, Vista) and we have a very slow ant task 
>> on Vista's computer. A task that take 1 minute on Mac OS, XP or Linux 
>> will take more thank 7 minutes on Vista.
>>
>> I tested with ant command line or from Eclipse, it's equal. And with -v 
>> option I see that all task are speed but the task end for 2 or 3 seconds 
>> and restart for 1-2 seconds, with task manager I see my CPU work (to 
>> 25%) then nothing, 25%, nothing, ...
>>
>> I tested on Dual Core laptop (4Go RAM) and single core computer (2Go 
>> RAM) under Vista : both are slow.
>>
>> I see here ( http://marc.info/?l=ant-user&m=122048687204453&w=2 ) that 
>> some people have same problem (but I found only this one, so maybe not 
>> all people under vista?).
>>
>> Anyone have seen this?
>>
>> Thanks
>>
>> Eric Cambray
>>     
>
> _________________________________________________________________
> You live life online. So we put Windows on the web. 
> http://clk.atdmt.com/MRT/go/127032869/direct/01/
>   

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message