ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Koxkorrita" <koxkorr...@laudio.info>
Subject jdk version for compiling. SOS
Date Fri, 26 Dec 2008 16:46:18 GMT
hello

 

In my pc i have installed the 1.6_10 jdk.

i must to compile, for generate one war for one 5.0 tomcat that runs into
one 1.4 jdk, my classes.

for this pourpose i make this into one build.xml file:

<javac destdir="${entornoBase}/${classes}"
includes="**/${path}/${filej}.*,**/${filej}.*"
excludes="**/*EJB/*.*,**/**ejb/**/*.*" classpath="${classpath}"
optimize="on" deprecation="on" source="1.4" target="1.6">

                  <src path="${entornoBase}/${fuentes}"/>

</javac>

 

but using the options: 

optimize="on" deprecation="on" source="1.4" target="1.6">

 always appears into my tomcat this:

2008-12-26 17:42:07,483
[ContainerBackgroundProcessor[StandardEngine[Catalina]]] ERROR
org.apache.catalina.startup.HostConfig - Exception while expanding web
application archive Goikogane.war

java.lang.UnsupportedClassVersionError:
com/goikogane/servlets/GOIKOInitServlet (Unsupported major.minor version
50.0)

        at java.lang.ClassLoader.defineClass0(Native Method)

        at java.lang.ClassLoader.defineClass(ClassLoader.java:539)

        at
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)

        at
org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLo
ader.java:1634)

 

can you help me for compiling the classes for make it compatible with the
1.4 jdk?

 

thanks


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message