ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ward Van Looy <fl_comm_l...@hotmail.com>
Subject RE: sound task - either not doing anything or infinitely looping
Date Sun, 09 Nov 2008 21:03:50 GMT

Thanks for replying; I've updated to the latest driver version of my sound card but no change.
I didn't think the problem would be in that area actually; I have a relatively recent card
I have no audio problems in any other kind of applications. But it was worth a try; appreciate
the response.
I was (and kinda still am) assuming the problem would be more on the Java/Ant side, specifically
something with the buildFinished listener the sound task sets to hook into the end of a build.
Unfortunately -debug doesn't provide any info about that as far as I can tell. 
I guess the only thing I could try is to find out exactly how the task plays the sounds, and
reproduce that in a standalone Java app to (dis)prove the problem is purely inside Ant. If
I get around to doing that I'll post back.
In the meantime, here's hoping someone else has ever stumbled upon the same symptoms and found
the exact cause and/or a solution.

Best regards,
Ward

> From: mgainty@hotmail.com
> To: user@ant.apache.org
> Subject: RE: sound task - either not doing anything or infinitely looping
> Date: Sun, 9 Nov 2008 11:43:40 -0500
> 
> 
> First thing I would check is to make sure the SoundCard vendor's driver is installed
and working
> Nota Bene: All of the available (Sound) drivers are supposed to be located in windows
/INF folder
> 
> I know my vendor's SC is so outdated that it wont work with any of the newer OS's
> 
> Martin 
> ______________________________________________ 
> Disclaimer and confidentiality note 
> Everything in this e-mail and any attachments relates to the official business of Sender.
This transmission is of a confidential nature and Sender does not endorse distribution to
any party other than intended recipient. Sender does not necessarily endorse content contained
within this transmission. 
> 
> 
> 
> 
>> From: fl_comm_loko@hotmail.com
>> To: user@ant.apache.org
>> Subject: sound task - either not doing anything or infinitely looping
>> Date: Sun, 9 Nov 2008 12:59:39 +0100
>> 
>> 
>> I'm getting what I think is very strange behaviour from the sound task. As I understand
it, this is supposed to play sounds at the end of a build, depending on whether the build
failed or not.
>> My first attempt came down to simply this:
>> 
>>     
>>         
>>         
>>     
>> 
>> This results in absolutely nothing being played, regardless of build success or failure.
I am positive that the files are in the correct location and that there is nothing out of
the ordinary with them.
>> I then started playing around with the attributes, and found that if I set the duration
to anything other than "0", for example:
>> 
>>     
>> 
>>         
>> 
>>         
>> 
>>     
>> 
>> 
>> This results in the sound being infinitely repeated, keeping the Ant process from
ever terminating until I kill it.
>> 
>> The value of "duration" doesn't have any influence on the behaviour; except when
it's set to 0 in which case again nothing at all happens (as expected). The value of "loops"
does not have any impact at all.
>> I used several different wav files and they all yield the same result.
>> I tried the sound task in all possible locations (inside an "init" target on which
everything else depends, inside its own target, at top level), and the result is always the
same.
>> Running with -verbose and -debug didn't yield anything relevant.
>> For completeness' sake, I'm running on Windows XP SP2, with jdk1.6.0_10 and ant-1.7.1.
>> 
>> Summing up, without optional attributes nothing happens; with any strictly positive
duration it loops forever. As far as I could google and search this and other mailing lists,
no-one else has ever reported this problem. I'm at a complete loss, I think for the first
time ever... on what seemed like a simple and fun icing on the cake of finishing up a script,
and d'oh! :-)
>> 
>> Thanks in advance for any tips,
>> Best regards,
>> Ward
>> 
>> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>> For additional commands, e-mail: user-help@ant.apache.org
>> 
> 


_________________________________________________________________
Explore the seven wonders of the world
http://search.msn.com/results.aspx?q=7+wonders+world&mkt=en-US&form=QBRE
---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message