ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pascal Lalonde <plalo...@comact.com>
Subject RE: Update Manifest
Date Tue, 28 Oct 2008 16:42:00 GMT
That's what I tough at the beginning. But they do exist.

- Pascal

-----Original Message-----
From: ray.harper@wachovia.com [mailto:ray.harper@wachovia.com]
Sent: October 28, 2008 12:32 PM
To: Ant Users List
Subject: Re: Update Manifest

You may be getting the error because you are trying to perform an update
and the file may not exist

Ray Harper, Jr.
Software Engineer II
Wachovia Corporation
1525 West WT Harris Blvd. Charlotte, NC, 28270
Tel: 704-427-1717 ? Fax: 704-427-3234 ? Mailcode: NC1077

CONFIDENTIALITY NOTICE:
The information accompanying this email transmission may contain
confidential or legally privileged information that is intended only for
the use of the individual or entity named in this message. If you are not
the intended recipient, you are hereby notified that any disclosure,
copying, distribution or reliance upon the contents of this email is
strictly prohibited. If you receive this email in error, please notify the
sender immediately.




Pascal Lalonde <plalonde@comact.com>
10/28/2008 11:55 AM
Please respond to
"Ant Users List" <user@ant.apache.org>


To
"user@ant.apache.org" <user@ant.apache.org>
cc

Subject
Update Manifest






I am attempting to update two manifest files from existing jar and war.

The goal of my ant task is to update their manifest file and jar the
parent folder.
This is what my task looks like:

<target name="copy-files">
<echo>********************************************************************</echo>
                <echo>Copying the binaries to configured
destination.</echo>
                <copy todir="${env.deploy.path}-${env.repos.revision}">
                                <fileset
dir="${env.source.path}/Optimizer/deploy"/>
                </copy>
                <tstamp/>
                <jar
destfile="${env.repos.username}-${DSTAMP}${TSTAMP}-${env.repos.revision}.zip"
basedir="${env.deploy.path}-${env.repos.revision}">
                                <manifest>
                                                <attribute name="Built-By"
value="${env.repos.username}"/>
                                                <attribute
name="Built-Date" value="${DSTAMP}${TSTAMP}"/>
                                                <attribute
name="Repository" value="${env.repos.url}"/>
                                                <attribute name="Revision"
value="${env.repos.revision}"/>
                                </manifest>
                                <manifest
file="${env.deploy.path}-${env.repos.revision}/local/comact_Optimizer_main.jar
" mode="update">
                                                <attribute name="Built-By"
value="${env.repos.username}"/>
                                                <attribute
name="Built-Date" value="${DSTAMP}${TSTAMP}"/>
                                                <attribute
name="Repository" value="${env.repos.url}"/>
                                                <attribute name="Revision"
value="${env.repos.revision}"/>
                                </manifest>
                                <!--manifest
file="${env.deploy.path}-${env.repos.revision}/web/EdgExpert.war"
mode="update">
                                                <attribute name="Built-By"
value="${env.repos.username}"/>
                                                <attribute
name="Built-Date" value="${DSTAMP}${TSTAMP}"/>
                                                <attribute
name="Repository" value="${env.repos.url}"/>
                                                <attribute name="Revision"
value="${env.repos.revision}"/>
                                </manifest-->
                </jar>
                <echo>[DONE]</echo>

<echo>********************************************************************</echo>
</target>

The copy is executed without any problem, right after the copy. The build
quits without any error, and manifest aren't updated. If I comment the two
last manifest call, everything gets executed without any problem.

I tried reading the doc to find "update" samples, but didn't find any.
Or maybe the manifest calls aren't done at the right place ?
Something important to know is that this script is not the one building
the jar and war files.

Thanks for your help,
Pascal


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message