ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From janylj <jan...@gmail.com>
Subject Re: Build failed when packaging the WAR
Date Wed, 01 Oct 2008 17:39:28 GMT

Just answer my own question in case that someone else meets the same problem.
The <webinf> should be:

      <webinf dir="web/WEB-INF">
        <include name="*.xml"/>
        <exclude name="web.xml"/>
      </webinf>



janylj wrote:
> 
> Hello,
> 
> I am trying to package a WAR with some xml in the WEB-INF folder.
> 
>   	<war destfile="${deploy.path}/${ant.project.name}.war"
> webxml="web/WEB-INF/web.xml">
>   	  <lib dir="${deploy.path}/war/lib"/>
>   	  <classes dir="${deploy.path}/war/classes"/>
>   	  <webinf>
>   		<fileset dir="web/WEB-INF">
>   	  	  <include name="*.xml"/>
>   		  <exclude name="web.xml"/>	
>   	    </fileset>
>   	  </webinf>
>   	</war>
> 
> The build failed because:
> BUILD FAILED
> build-custom.xml:51: The following error occurred while executing this
> line:
> build-custom.xml:92: problem opening
> /home/SomeProject/web/WEB-INF/restlet-servlet.xml
> 
> The problem is at <webinf> element. I checked restlet-servlet.xml
> permission. It's fine. Then I don't know how to put the
> restlet-servlet.xml into the WEB-INF folder in the WAR. Please help. Thank
> you.
> 

-- 
View this message in context: http://www.nabble.com/Build-failed-when-packaging-the-WAR-tp19764478p19765564.html
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message