ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Weintraub" <qazw...@gmail.com>
Subject Re: Subversion Ant Tasks
Date Tue, 29 Jul 2008 19:53:41 GMT
The Hudson people told me of a Hudson plugin that forces Hudson to use
Subversion 1.3 format in the work directory. That solved this
particular issue

--
David Weintraub
qazwart@gmail.com



On Tue, Jul 29, 2008 at 7:04 AM, Rod Mackenzie
<rod.n.mackenzie@googlemail.com> wrote:
> I used svnant a while back, here's a bit of the build file I used
>
>    <target name="init-svn">
>        <!--property name="svnant.home" value="svnant-1.0.0"/-->
>        <property name="svnant.home" value="svnant-1.1.0-RC2"/>
>
>        <!-- path to the svnant libraries.  -->
>        <path id="svn.classpath">
>            <fileset dir="${svnant.home}/lib">
>                <include name="*.jar"/>
>            </fileset>
>        </path>
>
>        <!-- load the svn task -->
>        <!--taskdef resource="svntask.properties"
> classpathref="svn.classpath"/-->
>        <typedef resource="org/tigris/subversion/svnant/svnantlib.xml"
> classpathref="svn.classpath"/>
>    </target>
>
> The differences to your example is that I include all the jars from the
> svnant lib directory which includes the javasvn.jar and use the antlib to
> include the tasks. Also the version of svnant maybe important I tried using
> 1.0.0 but kept getting exceptions which is why I moved to 1.1.0-RC2
>
> Rod
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message