ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mindspin311 <connoc.minds...@gmail.com>
Subject Re: hooks/post-commit not being called when commiting with Ant.
Date Wed, 30 Jul 2008 19:45:36 GMT

Turns out it was a problem with Atlassian Bamboo.. the post-commit in hooks
was sending the signal, but Bamboo wasn't following orders because that
specific project wasn't being changed. The problem is now solved.




David Weintraub wrote:
> 
> Commits are done via the Server, so the post-commit script gets called
> no matter what client you're using. That is, if you're not using the
> file:// URL for Subversion:
> 
> Incorrect:
> 
> svn cp file://project/trunk file://project/tags/REL-1.0
> 
> Correct:
> 
> svn cp http://server/repos/project/trunk
> http://server/repos/project/tags/REL-1.0
> svn cp svn://project/trunk svn://project/tags/REL-1.0
> 
> I would recommend that you use "print" statements throughout your hook
> to print to STDERR, and then purposely fail the hook to see if you can
> see the output. That will help you determine whether or not the hook
> is actually firing.
> 
> Copy your repository, and startup another server instance, and use
> that as a test bed. I have a special "xdev" repository defined in
> Apache for this type of experimenting.
> 
> --
> David Weintraub
> qazwart@gmail.com
> 
> 
> 
> On Mon, Jul 28, 2008 at 5:43 PM, mindspin311 <connoc.mindspin@gmail.com>
> wrote:
>>
>> What I'm doing is tagging a build in an ant script using a user 'build'.
>> This
>> is an actual user, and not something like apache or someone without a
>> shell
>> account.
>>
>> I've got automated builds triggered using Atlassian Bamboo when done from
>> the command line or doing a commit in a third party app like Eclipse.
>> This
>> works fine.
>>
>> The thing is, when I do an automated tag in my build script using <svn
>> javahl=${javahl}> ...... </svn>, it doesn't seem to get read in the
>> post-commit script.
>>
>> It seems to be either a problem with post-commit not being called when a
>> tag
>> is done, or it not being called when committing in ant.
>>
>> Anyone have any ideas?
>> --
>> View this message in context:
>> http://www.nabble.com/hooks-post-commit-not-being-called-when-commiting-with-Ant.-tp18700420p18700420.html
>> Sent from the Ant - Users mailing list archive at Nabble.com.
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>> For additional commands, e-mail: user-help@ant.apache.org
>>
>>
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/hooks-post-commit-not-being-called-when-commiting-with-Ant.-tp18700420p18741196.html
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message