ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Loehr, Ruel" <rlo...@pointserve.com>
Subject RE: ivy issues
Date Thu, 22 May 2008 19:43:54 GMT
It's probably related to configurations.

        ---------------------------------------------------------------------
        |                  |            modules            ||   artifacts   |
        |       conf       | number| search|dwnlded|evicted|| number|dwnlded|
        ---------------------------------------------------------------------
        |      default     |   0   |   0   |   0   |   0   ||   0   |   0   |
        |      compile     |   6   |   0   |   0   |   0   ||   2   |   0   |
        |       test       |   13  |   0   |   0   |   1   ||   8   |   0   |
        |       gendb      |   0   |   0   |   0   |   0   ||   0   |   0   |
        ---------------------------------------------------------------------


You are only retrieving things marked with the "compile" configuration.   I would expect you
to get the remaining four.......      What does the output look like in debug mode?  It might
provide more clues.



What do your dependency declarations look like?    Compile->* ?



-----Original Message-----
From: Bobby Quinne [mailto:elite.code.ninja@gmail.com]
Sent: Thursday, May 22, 2008 2:38 PM
To: user@ant.apache.org
Subject: RE: ivy issues



ruel loehr wrote:
>
> What is the output?
>
http://www.nabble.com/file/p17411879/ant.txt ant.txt


ruel loehr wrote:
>
> What is the output when running in debug mode?
>
> e.g.  ant -debug yourtarget
>

http://www.nabble.com/file/p17411879/ant-debug.txt ant-debug.txt
-----Original Message-----
From: Bobby Quinne [mailto:elite.code.ninja@gmail.com]
Sent: Thursday, May 22, 2008 1:01 PM
To: user@ant.apache.org
Subject: ivy issues


Hi,

I am experiencing a few issues that I have been unable to resolve.

1: On the ivy:resolve, entries for the various dependencies are retrieved,
the ivy-[revision].xml and pom/. Some of the jars are downloaded in the
processes, but not for all the dependencies. I checked on the ibiblio site
and the compiled jars are there. Any reason why there are not being
downloaded?

2: For my compile dependencies I have spring, spring-test, ejb3-persistence,
junit and log4j. Now these jars are in my cache, but only commons-collection
and junit are being retrieved with ivy:retrieve. I have confirmed spring is
there, and the ejb3-persistence jars...I'm stumped why they are not being
pulled across from the cache.

Any help appreciated.
--
View this message in context:
http://www.nabble.com/ivy-issues-tp17410046p17410046.html
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org



--
View this message in context: http://www.nabble.com/ivy-issues-tp17410046p17411879.html
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message