ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kathryn Rivard" <>
Subject Re: taskdef not receiving the classpath properly?
Date Wed, 16 Apr 2008 13:51:21 GMT
On Wed, Apr 16, 2008 at 7:19 AM, Steve Loughran <> wrote:

>  It was probably the RPM version getting in ahead of anything else...we
> changed the scripts in Ant1.7 so your own installation gets in there first.

Whatever you changed, it didn't work 100% for my system.  To get
Ant1.7 to run instead of 1.6, I had to remap /usr/bin/ant by hand, and
nuke /etc/ant.conf which I'm pretty sure is a fedora thing.  When
installing from a binary though I kinda expect to have to massage the
system to get it to work, so it wasn't a big deal.

>  2. you can also stick jars into ~/.ant/lib, so that different users can
> have stuff in the classpath, even with a root-only ANT_HOME/lib

Definitely tried that.  Putting things in ~/.ant/lib/ was just as
effective as ANT_HOME/lib (neither worked for 1.6 on my system, and
they failed in the same ways) -- I wish I could've figured out exactly
what was wrong to be able to tell you guys, but this one may remain a

Thanks Steve,

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message