ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Debbie Shapiro" <DShap...@cardiacscience.com>
Subject RE: Trouble with installation
Date Mon, 28 Apr 2008 19:44:40 GMT
Thanks so much for the quick response!

 think I have this working now. Part of the problem was having both the
JDK and JRE paths in my JAVA_HOME when I only needed the JDK there. I
also had to point to the JRE directory of my JDK path. I created a new
environment variable called JDK_HOME that only contains my JDK path as
well. I also had, for my ANT_HOME variable the higher level Ant
directory rather than the apache-ant-1.7.0 directory, which apparently
was causing some problems. So, apparently, Ant was a bit confused about
where it was looking for stuff.



Debbie Shapiro, Data Warehouse Manager
Office: 425.402.2233 
-----Original Message-----
From: glenn opdycke-hansen [mailto:glennoph@gmail.com] 
Sent: Friday, April 25, 2008 7:41 PM
To: Ant Users List
Subject: Re: Trouble with installation

What is the java home directory?
what is PATH and JAVA_HOME?

Also, you stated that the jdk was installed but later indicate that
jre was being used.

--glenn

On Fri, Apr 25, 2008 at 1:19 PM, Debbie Shapiro
<DShapiro@cardiacscience.com> wrote:
> Hello -
>
>  Let me preface this with saying I am not a Java guru by any means. I
am
>  trying to install Ant 1.7 in conjunction with a Pentaho Business
>  Intelligence installation. I had extracted the application into a
>  directory on my server and tried to create a build.xml but then
learned
>  that Ant needs the Java JDK installed and not just a JRE. I had
1.5.0_04
>  JRE installed. Downloaded 1.5.0_15 JDK and installed that on my
server.
>  Yesterday, when I tried to run Ant -diagnostics it indicated it was
>  still pointing to my _04 version even though I had changed my
JAVA_HOME
>  and PATH to point to the new installation. I uninstalled the _04
version
>  completely. However, when I try to run Ant -diagnostics now it is
giving
>  me the following error:
>
>
>
>  Exception in thread "main" java.lang.NoClassDefFoundError:
>  org/apache/tools/ant/Launch/Launcher
>
>
>
>  I checked my java version. And this all seems correct: Java(tm) 2
>  Runtime Environment, Standard Edition (build 1.5.0_015-b04) Java
>  JotSpot(tm) Client VM (build 1.5.0_15-b04, mixed mode, sharing)
>
>
>
>  I DO NOT have a CLASSPATH set. Only ANT_HOME, JAVA_HOME, PATH. What
am I
>  doing wrong here? I followed the instructions in the manual
completely.
>  Did not do any of the optional tasks.
>
>
>
>  Thanks in advance for any help!
>
>
>
>  Debbie Shapiro
>  Data Warehouse Manager
>  Cardiac Science Corporation * cardiacscience.com
>  3303 Monte Villa Parkway, Bothell, WA 98021
>  Office: 425.402.2233
>
>  Cardiac Science Corporation [NASDAQ: CSCX] is a global leader in
>  advanced cardiac diagnosis, resuscitation, rehabilitation, and
>  informatics products.
>
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message