ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim-at-Startupgeek <tim.wool...@gmail.com>
Subject Re: task won't run in cruise control but runs from windows command prompt...
Date Mon, 03 Mar 2008 23:19:29 GMT

Greetings - 
Just ran into this myself with our CC environment - your question about 'why
this will run from the command prompt but not from Cruise Control' is
something I just solved for us.  

Check the system account that Cruise Control is running under.  We're
running CCNet under Windows ourselves and the service account it uses didn't
have the same permissions as my account; it kept failing for that reason.

I ended up making it a domain admin of our environment to end any
outstanding permissions issues (we're a small shop and I don't want to make
a career out of simulating permissions issues for our servers).

Hope that helps.

~T


Christopher Styles wrote:
> 
> Hi,
> 
> I know this isn't a Cruise Control list, but I need some assistance
> with this issue, since it centers around Ant - and no one from the Cruise
> Contol list has responded... When I run the tasks below in cruise control
> 2.7.1, the second task fails, which happens to be dependent on the
> first...
> When I run them from the Windows command prompt they work great, but I'm
> not
> yielding the same results in Cruise Control... What's suppose to happen
> is,
> target "lib-ext" will be executed, but first the dependency target
> "lib-ext-test" gets executed. If the folder exists, it will set the
> "folder-exists" property. Then, Ant goes back to the "lib-ext" task and
> checks the dependency. If "folder-exists" is set, "lib-ext" will be
> executed. Otherwise, it won't.  In other words, the "lib-ext-test" target
> checks to see if the folder exists, and if it does, "lib-ext" ftps the
> files
> within the folder.... If the folder doesn't exist, "lib-ext" doesn't
> execute, and the process moves on to the next target in the sequence... As
> I
> stated earlier, it works great from the Windows command prompt, but in
> Cruise Control it fails and just says "folder doesn't exist"... Why won't
> this execute in Cruise Control like it does from the Windows command
> prompt...??? If someone could assist me with this I'd surely appreciate
> it...
> 
> <target name="lib-ext-test">
>    <available property="folder-exists"
>       file="${existingExt.dir}"/>
> </target>
> 
> <target name="lib-ext" if="folder-exists" depends="lib-ext-test">
>     <ftp server="${remoteHostName}"
>         userid="${remoteInstallUserId}"
> password="${remoteInstallPassword}"
>         remotedir="${remoteExtFtpDir}"
>         verbose="yes"
>         binary="yes"
>         action="put"
>         chmod="755">
>      <fileset dir="${existingExt.dir}">
>         <include name="*.jar"/>
>         <include name="*.properties"/>
>         <include name="*.txt"/>
>         <include name="*.xml"/>
>         <include name="*.xsd"/>
>      </fileset>
>     </ftp>
> </target>
> 
> Thanks
> Chris
> 
> 

-- 
View this message in context: http://www.nabble.com/task-won%27t-run-in-cruise-control-but-runs-from-windows-command-prompt...-tp15291117p15816645.html
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message