ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Murray, Mike" <...@ptc.com>
Subject Exec Hangs in Multi-Threaded Parallel
Date Mon, 18 Feb 2008 21:06:10 GMT
Can anyone tell me why the exec task, whether or not spawned, hangs in
parallel calls?  It works fine if I pass -DthreadCount=1.  It appears
the higher the threadCount used, the quicker it will hang, since
-DthreadCount=2 works for a while, but threadCount=5 hangs immediately.
This apparently happens when two exec tasks are called simultaneously.
Using a forked java task in similar fashion, hangs the same way.  The
parallel calls of BuildModule work fine when the macrodef uses the ant
task.
 
Thanks, Mike
 
    <parallel threadCount='${threadCount}'>
      <BuildModule name='wnc/Cadx' modroot='CadxHtmlUi/Cadx'
assembly='wnc' />
      <BuildModule name='wnc/Esi' modroot='wcEsi/Esi' assembly='wnc' />
      <BuildModule name='wnc/Explorer'
modroot='Windchill/DevModules/Explorer' assembly='wnc' />
    </parallel>
 
   <macrodef name="BuildModule">
      <attribute name="assembly"             default=""/>
      <attribute name="name"                 default="@{assembly}"/>
      <attribute name="modroot"/>
      <sequential>   
         <exec executable="ant" spawn="true" vmlauncher="false">
            <arg line="-f ${module_script} ${ant.arguments}
-Dmodroot=${viewroot}/@{modroot <mailto:-Dmodroot=${viewroot}/@{modroot>
} -Dcontext=@{assembly}"/ <mailto:-Dcontext=@{assembly}"/> >
         </exec>



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message