ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Agnew <br...@oopsconsultancy.com>
Subject Re: XMLtask trouble with <insert>
Date Sun, 03 Feb 2008 17:45:23 GMT
Hi Zakir,

Probably best to mail the XMLTask mailing list with XMLTask-specific 
questions. xmltask-users@lists.sourceforge.net 
<mailto:xmltask-users@lists.sourceforge.net>

I suspect you need to specify an XPath with the appropriate namespace 
info. e.g. in the below use:

path="/*[local-name()='bean']"

or

path="/:bean"

Brian

Zakir wrote:
> Hi all.
>
> I am using Ant 1.70 and XMLtask 1.15.1
>
> This is my scenario: I have a simple bean definition file.  I need to run
> ant tasks to inject beans into this file.  My bean definition file looks
> something like:
>
> <beans xmlns="http://www.springframework.org/schema/beans"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xmlns:aop="http://www.springframework.or.......>
>         
>             <bean>....</bean>
>             ........
> </beans>
>
> Now, if I try and run an <insert> task, with path="/beans", it isn't able to
> locate the xpath and doesn't insert anything.  Now, if I remove all the
> information from the <beans> root tag, it works!  Is this some kind of bug
> with XMLtask? 
>
> Thanks!
>
>   

-- 
Brian Agnew                  http://www.oopsconsultancy.com
OOPS Consultancy Ltd         brian @ oopsconsultancy.com
Tel: +44 (0)7720 397526
Fax: +44 (0)20 8682 0012


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message